Back to overview
Maintenance

Scheduled Platform Maintenance - Infrastructure Migration

May 2, 2026 at 3:00pm UTC  –  May 2, 2026 at 7:00pm UTC
Affected services
Enrich
LinkedIn Contact Data

Resolved
May 2, 2026 at 7:00pm UTC

Maintenance ended

Created
May 2, 2026 at 3:00pm UTC

We're migrating to upgraded backend infrastructure. During the maintenance window:

  • The Minerva web app (app.minerva.io) may be unavailable or unresponsive
  • All API endpoints (Enrich, LinkedIn Contact Data) will be unavailable or return errors
  • Authentication may be intermittently disrupted

What to do: Plan any time-sensitive enrichment runs or dashboard work for before 11 AM ET or after 3 PM ET on Saturday.

We'll update this status page as the migration progresses and confirm when normal service resumes. For any questions, please contact your account manager or justin@minerva.io for any questions.